Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

SiteLink Support & Sales

Welcome to StorageForum!
If you're new take a look at the StorageForum Terms of Use and don't forget to check out Daily Dilbert!

Is there a way to turn on/off CC autopay?

Updated from a really old version (standalone) of Sitelink fairly recently, and am just getting around to filling in the operational gaps.

I am pushing to get people onto autopay, but it is not working? They sign up and make manual payments online, but when they go through and check the "autopay" option, it does not work

Is there a setting in Sitelink or Corporate somewhere to toggle that option on/off that I need to check on?

Comments

  • MamaDuke7MamaDuke7 CARegistered User, Daily Operations Certified, Advanced Operations Certified, Administrator Certified, myHub Certified ✭✭✭✭✭
    So once they opt in to autopay online, you go into their ledger settings and it still says "None" under Auto Bill?

    If that's the case, it sounds like there is a problem with the coding.  I'm digging a bit more.  I'll let you know if I find anything else.
  • MamaDuke7MamaDuke7 CARegistered User, Daily Operations Certified, Advanced Operations Certified, Administrator Certified, myHub Certified ✭✭✭✭✭
    Okay, so just in case you're dealing with user error on the part of the customer: the automatic payment online has to be setup separately from the payment process.  Checking the box during the payment only saves the card for future non-recurring use.  There is a separate tab for automatic payments.

    Is their account showing a note that automatic payment has been updated on the website?

    There is nothing in the Corporate Controls except to allow online payments or not allow them.
  • mistoremistore NARegistered User
    edited January 23
    So; if I go:

    Tenant ---> Payment ---> Ledger Settings ---> Auto Bill;

    -Credit Card is checked
    -Auto bill on day past due, is set to 0
    -Credit card info is valid
    -AVS info is valid


    *This is looking at them through Sitelink.


  • mistoremistore NARegistered User
    MamaDuke7 said:
    Okay, so just in case you're dealing with user error on the part of the customer: the automatic payment online has to be setup separately from the payment process.  Checking the box during the payment only saves the card for future non-recurring use.  There is a separate tab for automatic payments.

    Is their account showing a note that automatic payment has been updated on the website?

    There is nothing in the Corporate Controls except to allow online payments or not allow them.
    I will talk with them, the first time (last month) it was an issue I chatted with them and had them verify that they had checked Autopay; they said there was a box for that, and that they had selected it.

    Is there a way I can see what the customer sees; or do I need to set up my own account and card and run through the process?
  • mistoremistore NARegistered User
    This is the notification I got:
  • MamaDuke7MamaDuke7 CARegistered User, Daily Operations Certified, Advanced Operations Certified, Administrator Certified, myHub Certified ✭✭✭✭✭
    mistore said:
    This is the notification I got:
    This didn't turn on Autopay.  The line says Automatic Bill Pay Changed: NO.  So they changed their card info, but did not turn autopay on.  The box they checked specifically says "Check this box to save your credit card information for future nonrecurring use."

    To turn it on, they have to go to the tab for Automatic Billing (not the Payment tab) and complete that part.
  • mistoremistore NARegistered User
    MamaDuke7 said:
    mistore said:
    This is the notification I got:
    This didn't turn on Autopay.  The line says Automatic Bill Pay Changed: NO.  So they changed their card info, but did not turn autopay on.  The box they checked specifically says "Check this box to save your credit card information for future nonrecurring use."

    To turn it on, they have to go to the tab for Automatic Billing (not the Payment tab) and complete that part.
    That was the second notification, after they had turned it on, and I had them try again and recheck setting. This was the first notice I got:
  • mistoremistore NARegistered User
    The way I read this is; they originally turned on autopay, thus the "New AutoBill: YES" and the "Automatic Bill Pay changed: YES" tags.

    On the second notification, after I had them double check, those fields are tagged NO, because it was already on and the status wasn't changed?

    It did not auto pay last month (after the first change) and it did not auto pay this month (after the recheck of the selection).

  • MamaDuke7MamaDuke7 CARegistered User, Daily Operations Certified, Advanced Operations Certified, Administrator Certified, myHub Certified ✭✭✭✭✭
    You're right.  I overlooked that line!

    So, are some of your autobill customers working?  Or are they all not working?

    Do you run them manually from a reminder, or do you use the batch process to do it automatically?

  • mistoremistore NARegistered User
    So, right now, this is the only one. He is a friend, and works right up the road; I wanted to run him through it so I could understand how it works, and have an easier time with any issues that came up. I wanted to make sure I was on top of things before I put a push on getting more people.
  • mistoremistore NARegistered User
    MamaDuke7 said:
    Do you run them manually from a reminder, or do you use the batch process to do it automatically?

    Ooh... That might be the disconnect. It's not a pure autopay system? I need to manually "trigger" the processing every month?

    I see that now under the "Credit Card" tab.

    Does this mean, since I'm on an Anniversary payment schedule, that I will need to process daily (depending on volume)?
  • MamaDuke7MamaDuke7 CARegistered User, Daily Operations Certified, Advanced Operations Certified, Administrator Certified, myHub Certified ✭✭✭✭✭
    edited January 23
    Yes.  But if you go to Setup: Program Defaults: Batch you can turn it on to run automatically each month.

    Otherwise, where it says Credit Cards in the reminders list, you need to go in and process those when they come up.  (I find it easier to use the batch automatic processing, though.)
  • mistoremistore NARegistered User
    So, the "problem" was me...    :D




  • mistoremistore NARegistered User
    If I'm reading it correctly, if I set it up like this, it should check for, and process autopay accounts every night.


  • MamaDuke7MamaDuke7 CARegistered User, Daily Operations Certified, Advanced Operations Certified, Administrator Certified, myHub Certified ✭✭✭✭✭
    Perfect!
Sign In or Register to comment.