On-line Payment difficulties

Is anyone else having constant problems with tenants being able to make payments on-line?  Every month we have at least 15 people who call in saying they are unable to complete payments due to a variety of reasons from timed out to change your password.  I have communicated with Sitelink numerous times and they give me this long explanation to give the customer to use Google Chrome, clear all cookies, etc.  I feel this is an unreasonable thing to ask of my clients, many of whom are not technically inclined.  We use Sitelink Merchant Services and StorEdge designed our website.  Any info would be greatly appreciated!!!  I'm so frustrated!!

Comments

  • themage
    themage ORRegistered User, Daily Operations Certified, Advanced Operations Certified, Administrator Certified, myHub Certified ✭✭✭✭
    As near as I can recall, there are several of us experiencing this. From my research, there seems to be 2 different problems, and it doesn't matter what browser the tenant is using, or whether they have cleared the cache.

    The first problem is the way the payment page is buried in a "frame". If StorEdge could redesign that part of it to operate more directly, it would eliminate a lot of the problem. This one causes "too many redirects" "use another browser" and "clear the cache" type errors. 

    The other issue seems to be on the payment server side of things, and happens less often. I think that one usually shows the password or timed out error. 

    For the moment, there is very little we can do about it, except to take payment over the phne when the website doesn't work.
  • ShedStuff
    ShedStuff NARegistered User ✭✭✭
    I would strongly encourage all to sign up for Ask An Expert on Tues as I use that forum to help me navigate thru SiteLink...Jim is very knowledgeable! 
  • GoGreen
    GoGreen CORegistered User ✭✭✭
    We also have recently had this problem show up. It only started happening after we were required to change our credit card processor, so now SiteLink/etc. runs all of that. It is frustrating for our tenants. Hopefully they see this thread and work on getting the online payments fixed!
  • ESS
    ESS TXRegistered User, Daily Operations Certified, Advanced Operations Certified, Administrator Certified, myHub Certified ✭✭✭✭✭
    GoGreen said:
    We also have recently had this problem show up. It only started happening after we were required to change our credit card processor, so now SiteLink/etc. runs all of that. It is frustrating for our tenants. Hopefully they see this thread and work on getting the online payments fixed!
    If you really want them to see it, post it in the other Self Storage Forum. They only seem to communicate there....it's pretty rogue here.
    Angela
  • zacteam
    zacteam GARegistered User
    Out tenants are also having this problem when they want to make a payment online.  I have been talking with the techs for almost two months.  They tell me it's resolved and when I say it's not, they continue to point fingers at our tenants and what browser they're using.  Very frustrating.  I see from ESS that this message needs to be posted to Self Storage Forum for the techs to see it.  All I know is that we didn't have a problem and now we do.  
  • teesee150
    teesee150 MIRegistered User ✭✭
    Been having this problem for years. Their website portal absolutely one of the worst I have ever seen. So many of my tenants hate it and find it unusable. Sitelink tech support is useless, even more so now that Storable bought them out. This and the forced switch to their CC processing, why is anyone staying with Sitelink? The day they tell me I have to switch CC processors will be the final straw and I will leave to find another software solution if not before then.
  • storable_support
    storable_support TXRegistered User, Registered Moderator, Community Manager ✭✭✭
    Hi, @teesee150. We're sorry to hear this, but thank you for sharing your feedback. We'd love an opportunity to help resolve these browser issues for you. It's likely the cause is related to your template being in an iFrame. The quickest way we can troubleshoot would be via phone. Please give us a call at your convenience at, 919-865-0789, Option 2. Thank you, Amy C.
  • Ahoy
    Ahoy CTRegistered User
    edited January 5
    I have had the issue with redirects but I think tech support may have just helped figure out our issues. Customers using Chrome and Edge were getting too many redirect errors. Tech support checked my settings and saw I was still set to use sitelink stores site as my website in the corporate control center. Make sure you don't have that selected as well. 
  • themage
    themage ORRegistered User, Daily Operations Certified, Advanced Operations Certified, Administrator Certified, myHub Certified ✭✭✭✭
    @Ahoy
    Check with the people hosting your website. Most of the "too many redirects" and "clear your cache and try again" errors are being caused by the iFrame mentioned by storable_support. It should be a simple fix once you get to the right person. We have a storEDGE website and storable support was able to fix it pretty quickly.

  • Ahoy
    Ahoy CTRegistered User
    @themage yeah, they actually got ahold of me not too long after posting with the fix (fingers crossed it works for customers too). I edited the post with the fix, I just wish they gave me the info when I called the first time, but it's working so I'll be thankful for that lol. 

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

© 2018 SiteLink Software, LLC. All Rights Reserved

Terms of Use  |  Privacy Policy   |  Cookies Policy   |  Help  |  Contact Community Manager   |  Change Marketplace Ads