Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to StorageForum!
If you're new take a look at the StorageForum Terms of Use and don't forget to check out Daily Dilbert!

Topaz Signature Pads Not working with Window 10 updates

ImbusImbus OHRegistered User
Is anyone else having problems using topaz signature pads for esign if you took the most recent window 10 update?  Sitelink has my case number which was started on June 26th and still haven't got a respond from them and just seeing if anyone else has figure out a fix?

Comments

  • Sue_CSue_C NADaily Operations Certified, Advanced Operations Certified, Administrator Certified ✭✭✭✭✭
    @Imbus, please call tech support and give them your case number. The issue could be the topaz driver, Explorer, Java or something else. Here's the number: 919-865-0789 (option 2)
  • ImbusImbus OHRegistered User
    I have already called 3 times this month and still no fix! I have 4 locations with this problem.
  • Sue_CSue_C NADaily Operations Certified, Advanced Operations Certified, Administrator Certified ✭✭✭✭✭
    @Imbus, please PM your contact directly to get this resolved, thanks.
  • Sue_CSue_C NADaily Operations Certified, Advanced Operations Certified, Administrator Certified ✭✭✭✭✭
    Tech support has confirmed a fix for this.

    Thanks again @Imbus for being the guinea pig on this fix ahead of time! It's now official for everyone.

    This is what you need to do:

    1. Test the Topaz Signature Pad in Chrome. Open esignportal.sitelink.com in Chrome and see if the pad works.

    2. Confirm that your Topaz Signature Pad works properly in Chrome.
    IMPORTANT: If your Topaz Signature Pad is NOT working in Chrome, you have a different issue such as a driver and the following steps will not help.

    3. Open IE->Tools->Internet Options->General->Browser History->Settings. Change this to "Every time I visit the web page".

    4. Test your Signature Pad in SiteLink.


Sign In or Register to comment.